Our new posting editor bugs

View previous topic View next topic Go down

default Our new posting editor bugs

Post by melodiccolor on Thu Jun 13, 2013 8:07 pm

Our hosts have introduced a brand new posting editor that is completely revamped.  It can do many new things.  However, it does have some bugs.

You will find it is incompatible with Internet Explorer so posts will not show nor will PMs work.  Images won't show if you use the image tab because it inserts another http?//: at the beginning.

One user at our host forum noted these bugs using IE:


Muddle Manor wrote:Muddle ManorUpdate on my end.

    I have now been asked by frustrated members if I will, as administrator, assist in editing emails into forum posts for them.  Of course I'm willing to help make this transition easier for them while we all wait for fixes to be implemented.  But I need to point out what a sad state of affairs it is when an Administrater of a forum needs to assist in this way.  The text editor is a major component of a forum-based environment.  When it goes wrong, it's devastating to the community.  I hope you're able to implement a fixed version soon.  My members have agreed it's best to just drop all activity until this is resolved.

    I have my profile set to display I use IE.  I do use other browsers.  However, I always use IE to test my pages as a very base minimum.  (Bearing in mind, that's how most computers come out of the box and many users, for whatever reason, don't upgrade.)  So the following two issues are from an IE perspective.  I encourage your team to not ignore IE specific issues.  I hope the following information is helpful.

    1.
    I've tested between the Editor Modes, and each seem equally glitchy when it comes to format tags.  The application's ability to process the tags seems sporatic at best. It appears that extensively formatted posts have more issues with disappearing (or hidden) tags than moderately formatted ones.

    2.
    While editing posts, entire sections of text will be completely removed.  There is no option but to cancel the edit, copy the text from the forum post (outside the editor) and replace the text via edit before editing what you were there to edit in the first place. This creates a nearly non-functional experience due to the unpredictability and frustration.  (I, personally, believe this must be related to point #1 because the missing text appears to be happening at moments of format changes.)







In addition, I noted these bugs:


melodiccolor wrote:Well this is interesting, you can go back and change a portion of your post by highliting and changing it, but if you do, and you go back to your current part in the post, it retains the old settings that were there in the earlier part before the change.  You have to reset the settings again for where you are now.  So I am in the wrong font.

OK, html coding for size still does show. Interesting

Edited to add that when I went down to the bottom of the post, the settings did return to where they were just above, but not on the portion inserted in the middle.  Very odd quirk.







They are working on the problem of the emoticon displays.


For more information on what our new editor can do, see http://funhsps.niceboard.org/t1164-some-of-the-things-we-can-do-with-forums#55142

As you can see, just copying and pasting to quote retains the settings of the text quoted, another bug.  Yet the text in the quote reverted to standard at the same time.

Please post here if you find any other problems using the new browser.


Last edited by melodiccolor on Tue Oct 28, 2014 8:23 pm; edited 1 time in total

_________________
Life is complex.  Parts of it are real and parts of it are imaginary.  (read in a novel by Gregory Benford.)

Absurdity is one of the great joys of life.

All you need for a rich life is to see more.
avatar
melodiccolor
Admin

Posts : 11746
Join date : 2008-04-27
Location : The Land of Seriously Sombrerosy Wonky Stuff

View user profile

Back to top Go down

default Re: Our new posting editor bugs

Post by melodiccolor on Fri Jun 14, 2013 10:13 pm

melodiccolor wrote:Our hosts have introduced a brand new posting editor that is completely revamped.  It can do many new things.  However, it does have some bugs.

You will find it is incompatible with Internet Explorer so posts will not show nor will PMs work.  Images won't show if you use the image tab because it inserts another http?//: at the beginning.

One user at our host forum noted these bugs using IE:


Muddle Manor wrote:Muddle ManorUpdate on my end.

    I have now been asked by frustrated members if I will, as administrator, assist in editing emails into forum posts for them.  Of course I'm willing to help make this transition easier for them while we all wait for fixes to be implemented.  But I need to point out what a sad state of affairs it is when an Administrater of a forum needs to assist in this way.  The text editor is a major component of a forum-based environment.  When it goes wrong, it's devastating to the community.  I hope you're able to implement a fixed version soon.  My members have agreed it's best to just drop all activity until this is resolved.

    I have my profile set to display I use IE.  I do use other browsers.  However, I always use IE to test my pages as a very base minimum.  (Bearing in mind, that's how most computers come out of the box and many users, for whatever reason, don't upgrade.)  So the following two issues are from an IE perspective.  I encourage your team to not ignore IE specific issues.  I hope the following information is helpful.

    1.
    I've tested between the Editor Modes, and each seem equally glitchy when it comes to format tags.  The application's ability to process the tags seems sporatic at best. It appears that extensively formatted posts have more issues with disappearing (or hidden) tags than moderately formatted ones.

    2.
    While editing posts, entire sections of text will be completely removed.  There is no option but to cancel the edit, copy the text from the forum post (outside the editor) and replace the text via edit before editing what you were there to edit in the first place. This creates a nearly non-functional experience due to the unpredictability and frustration.  (I, personally, believe this must be related to point #1 because the missing text appears to be happening at moments of format changes.)







In addition, I noted these bugs:


melodiccolor wrote:Well this is interesting, you can go back and change a portion of your post by highliting and changing it, but if you do, and you go back to your current part in the post, it retains the old settings that were there in the earlier part before the change.  You have to reset the settings again for where you are now.  So I am in the wrong font.

OK, html coding for size still does show. Interesting

Edited to add that when I went down to the bottom of the post, the settings did return to where they were just above, but not on the portion inserted in the middle.  Very odd quirk.







They are working on the problem of the emoticon displays.


For more information on what our new editor can do, see http://funhsps.niceboard.org/t1164-some-of-the-things-we-can-do-with-forums#55142

As you can see, just copying and pasting to quote retains the settings of the text quoted, another bug.  Yet the text in the quote reverted to standard at the same time.

Please post here if you find any other problems using the new browser.

OK, new bug has appeared.  You can't quote and get your cursor out of the quote box unless you click the switch editing mode icon (the paper looking one on the far right).  They are working on things, but new bugs keep appearing as they work to solve things.  

_________________
Life is complex.  Parts of it are real and parts of it are imaginary.  (read in a novel by Gregory Benford.)

Absurdity is one of the great joys of life.

All you need for a rich life is to see more.
avatar
melodiccolor
Admin

Posts : 11746
Join date : 2008-04-27
Location : The Land of Seriously Sombrerosy Wonky Stuff

View user profile

Back to top Go down

default Re: Our new posting editor bugs

Post by melodiccolor on Fri Jun 14, 2013 10:26 pm

I just got word they are working on debugging over the weekend, so at least they are not waiting until monday to get started on it.

_________________
Life is complex.  Parts of it are real and parts of it are imaginary.  (read in a novel by Gregory Benford.)

Absurdity is one of the great joys of life.

All you need for a rich life is to see more.
avatar
melodiccolor
Admin

Posts : 11746
Join date : 2008-04-27
Location : The Land of Seriously Sombrerosy Wonky Stuff

View user profile

Back to top Go down

default Re: Our new posting editor bugs

Post by melodiccolor on Sat Jun 15, 2013 2:26 pm

Apparently, there is an issue posting images with google chrome.  So far the only browser that works with the fewest bugs with the new editor is Firefox.

_________________
Life is complex.  Parts of it are real and parts of it are imaginary.  (read in a novel by Gregory Benford.)

Absurdity is one of the great joys of life.

All you need for a rich life is to see more.
avatar
melodiccolor
Admin

Posts : 11746
Join date : 2008-04-27
Location : The Land of Seriously Sombrerosy Wonky Stuff

View user profile

Back to top Go down

default Re: Our new posting editor bugs

Post by melodiccolor on Wed Jun 19, 2013 3:48 pm

The image tab no longer works.  To post an image, just use the [img][/  ] (insert img between [] after the /) codes on each side if the link.

_________________
Life is complex.  Parts of it are real and parts of it are imaginary.  (read in a novel by Gregory Benford.)

Absurdity is one of the great joys of life.

All you need for a rich life is to see more.
avatar
melodiccolor
Admin

Posts : 11746
Join date : 2008-04-27
Location : The Land of Seriously Sombrerosy Wonky Stuff

View user profile

Back to top Go down

default Re: Our new posting editor bugs

Post by melodiccolor on Sat Jun 22, 2013 5:51 pm

Updates:


  • Our old smiley box is back.
  • The cursor will now go below the quote box in WYSSIWIG mode
  • The links tab works
  • PMs now work in IE, but they are still working on full compatibility so some freezing may still occur

  •  mobile devices are still not fully compatable with the new editor


  • the image tab still is not working properly so we need to use the img /img tabs to insert images


For more information, please see Only topic, new editor over at Forumotion's forum.

_________________
Life is complex.  Parts of it are real and parts of it are imaginary.  (read in a novel by Gregory Benford.)

Absurdity is one of the great joys of life.

All you need for a rich life is to see more.
avatar
melodiccolor
Admin

Posts : 11746
Join date : 2008-04-27
Location : The Land of Seriously Sombrerosy Wonky Stuff

View user profile

Back to top Go down

default Re: Our new posting editor bugs

Post by melodiccolor on Fri Jun 28, 2013 10:56 pm

New Editor For Forumotion Forums has official updates on what work has been done.

_________________
Life is complex.  Parts of it are real and parts of it are imaginary.  (read in a novel by Gregory Benford.)

Absurdity is one of the great joys of life.

All you need for a rich life is to see more.
avatar
melodiccolor
Admin

Posts : 11746
Join date : 2008-04-27
Location : The Land of Seriously Sombrerosy Wonky Stuff

View user profile

Back to top Go down

default Re: Our new posting editor bugs

Post by melodiccolor on Tue Aug 06, 2013 4:55 pm

Update; most bugs seem to be fixed. However I noticed the list function still doesn't function correctly and links don't show in internet explorer (according to Anarkandi) as a different color.

_________________
Life is complex.  Parts of it are real and parts of it are imaginary.  (read in a novel by Gregory Benford.)

Absurdity is one of the great joys of life.

All you need for a rich life is to see more.
avatar
melodiccolor
Admin

Posts : 11746
Join date : 2008-04-27
Location : The Land of Seriously Sombrerosy Wonky Stuff

View user profile

Back to top Go down

default Re: Our new posting editor bugs

Post by melodiccolor on Wed Sep 04, 2013 4:33 pm

OK, Internet Explorer still does not work with our new editor as of last night. If you use it, switch to another browser for here.

_________________
Life is complex.  Parts of it are real and parts of it are imaginary.  (read in a novel by Gregory Benford.)

Absurdity is one of the great joys of life.

All you need for a rich life is to see more.
avatar
melodiccolor
Admin

Posts : 11746
Join date : 2008-04-27
Location : The Land of Seriously Sombrerosy Wonky Stuff

View user profile

Back to top Go down

default Re: Our new posting editor bugs

Post by melodiccolor on Tue Oct 28, 2014 8:23 pm

While there are still problems with Internet Explorer with this editor, it looks like no further work is being done to rectify it, so I am changing this thread from a sticky to a normal thread. I'll keep you updated on any news in the technical glitches thread.

_________________
Life is complex.  Parts of it are real and parts of it are imaginary.  (read in a novel by Gregory Benford.)

Absurdity is one of the great joys of life.

All you need for a rich life is to see more.
avatar
melodiccolor
Admin

Posts : 11746
Join date : 2008-04-27
Location : The Land of Seriously Sombrerosy Wonky Stuff

View user profile

Back to top Go down

default Re: Our new posting editor bugs

Post by Sponsored content


Sponsored content


Back to top Go down

View previous topic View next topic Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum